많은 아이폰4 프로그래밍 책은 대부분 XCode 4.1에 맞춰져 있습니다. XCode 는 버전별로 달라지는 사항들이 너무나 많기 때문에 초보자의 경우 책과 같은 버전을 사용하는게 편합니다.

아래에서 받을 수 있으며 애플 개발자 권한이 있어야합니다.

XCode 4.1 for Lion

XCode 4.1 for Snow Leopard

[참고] – 모두 Snow Leopard 용
XCode 4 (iOS SDK 4.3)
XCode 4.0.1 (iOS SDK 4.3)
XCode 4.0.2 (iOS SDK 4.3)